
UNIT 5 

DATA VISUALIZATION 

5.1 Create tables in a report 

Microsoft Excel is a beneficial tool for recording and tracking many processes, including in 

finance and marketing analysis. When we have multiple data sources we want to track in a 

spreadsheet, creating a report can help us organize and review data more effectively. 

Additionally, we can create reports using different methods, depending on our purpose for using 

the application.  

The following approaches show how to create a report in Microsoft Excel, using several 

methods: 

1. Display data in charts 

One method to create a report is to display data in a graph or chart. Excel has several types of 

charts you can set up in your spreadsheet, including line graphs, pie charts and tables. To create 

a visual report using graphs, use the following steps: 

1. Enter the data into the sheet using the "Insert" option in the program toolbar. 

2. After the data is in the sheet, find the "Select data" option to choose the information you 

want to display. This gives you a basic chart display, but you can change the chart design 

to a different style. 

3. Select the style of graph you want for your report from the "Chart design" tool in the 

menu. 

2. Create a pivot table to organize data 

A pivot table in Excel creates a table of summarized values from large sets of data. If you have 

an extensive amount of data to aggregate into informational reports, you can create a pivot table 

to make this information more accessible. Create your report using PivotTables by following 

these steps: 

1. Under the "Insert" option, select "PivotTable" in the menu. 

2. Select the range and location of the data you want to include in the table. 

3. Enter the labels for the reference and values fields of the new table and arrange it in your 

sheet. 

4. Choose the calculation you want the table to measure from the data, such as the average 

or maximum and minimum, and update the pivot table. 

As you update the various data connecting to the pivot table, the chart also updates to display 

the information according to your parameters. 



3. Separate the data types of your reports 

With large data, consider separating numerical data values from visual and text information. 

Excel allows you to create multiple sheets within a workbook and multiple pages within a sheet. 

This means you can visualize data in charts and graphs on one sheet, tabular data on another 

and any text values on a different sheet. Using this method creating reports in Excel is 

beneficial, for organizing and monitoring changes in data more effectively. 

4. Add page headers 

To print or export, reports need to have page headers. Use the steps below to insert headers and 

prepare reports for printing and exporting: 

1. Navigate to the menu and select "Insert." From here, choose "Text," then "Header and 

footer." 

2. Enter the name of your report in the related field and format the text according to your 

preferences, like large or bold text. 

3. Repeat this process for each of the pages you want to include in the printed report. 

4. If you want to omit certain sheets from your report, right-click on the corresponding tabs 

and select "Hide." 

5. Format and print reports 

When printing your report, you can change the layout so you're able to fit it to the printer paper. 

The following steps show how to format and print Excel reports: 

1. For visual data in graphs, charts or pivot tables, change the page to "Landscape" 

orientation under the print settings. 

2. Choose the option that allows you to fit all your report columns on a single page. 

3. Click "OK" to print the workbook as individual pages. 

4. If you're sending your reports through email, save the document as a .pdf file for 

compatible delivery. 

Applications of Excel reports: 

Microsoft Excel provides a range of tools for organizing and evaluating various data. Excel 

reports make up one program feature that can be useful for applications in different fields, 

including: 

 Finance and accounting 

Excel reports are often applicable to financial documentation and analysis. The report 

feature gives finance professionals the ability to create visual representations of critical 

data companies rely on to make important decisions. For instance, accounting 



professionals and bookkeepers can use Excel reports to track and evaluate various 

metrics, including budgets, incomes and expenses. 

 Sales and marketing 

Sales metrics like conversion rates, customer satisfaction, sales transactions and 

inventories are several factors professionals in this industry may include in an Excel 

report. For instance, the graphing function can show changes in customer purchases over 

time so sales teams can report on the performance of current practices. In marketing, 

Excel is applicable to creating reports for activities like campaign progress, budget 

analysis, market analysis and strategy performance can be common uses of the program. 

 Human resources 

Reports in Excel are also useful for documenting hiring practices and analytics in 

businesses. Managers can enter information regarding current processes, including 

application numbers, interview invites and successful hires. Reports are also applicable to 

measuring growth rates among staff members within different departments of a company. 

This range of documentation tools Excel features is often helpful for organizing and 

monitoring onboarding and employee metrics, too. 

How maximize use of Excel's report features? 

Consider the following tips to maximize your use of Excel's report features: 

 Combine reports on a dashboard. If you have multiple reports you want to track on one 

page, create a dashboard to display the most important aspects of the reports. 

 Use timelines or interactive elements. Timelines and info graphics or layered charts can 

provide additional approaches to including relevant and current topics of interest in a 

dashboard report. 

 Create backups of your data reports. As you update information in your documents, 

create backup files that you can use in the event you lose data or report documentation. 

 Use formatting tools when arranging data. When entering or importing data into 

Excel, use tools to clean data and wrap elements within the cells of your sheet. 

 Delete blank rows for more accuracy. Eliminate blank rows and empty cells to increase 

the accuracy of your data analysis and reporting, which can otherwise affect the 

calculations excel makes when summarizing information. 

 Include column headers when charting data. Include the column headers in the text 

fields as you select the range of data you're documenting in your report. 

5.2 Visualize data as a chart 

Excel is widely used for data analysis owing to its excellent data visualization features. The data 

visualization capability of Excel allows for building insightful visualizations. Every chart in 



Excel has its own significance. Excel provides many built-in charts, which can be beautifully 

leveraged to use data correctly. 

Defining Data Visualization 

Data visualization is a graphical representation of data. By utilizing charts, graphs, maps, etc., 

we can provide a simple and accessible way to understand our data and identify trends and 

outliers within our datasets. Note that Excel uses the term "chart" to mean a "plot". For 

example, a bar plot is called a bar chart in Excel terminology. 

Example Dataset 

We first need a dataset to work with before creating any visualizations. Simple dataset 

containing sales data for a local electronics store is shown below. The dataset contains 

information on the number of units sold for various product types in 2022 and totals for 

columns and rows. 

Month TVs Mobile Phones Laptops Total 

1/1/2022 145 335 82 562 

2/1/2022 145 362 126 633 

3/1/2022 105 311 95 511 

4/1/2022 171 259 93 523 

5/1/2022 178 277 107 562 

6/1/2022 167 292 145 604 

7/1/2022 200 385 77 662 

8/1/2022 181 388 78 647 

9/1/2022 152 291 83 526 

10/1/2022 143 345 102 590 

11/1/2022 114 399 99 612 

12/1/2022 109 250 101 460 

Total 1810 3894 1188   

 

Alternatively, you can import the dataset using the following steps: 

 Open Excel and create a new workbook. 

 Copy the dataset above and paste it into cell A1 

Format the cells as needed (e.g., adjust column width, apply bold formatting to headers, etc.). 

Creating Basic Charts in Excel 

Excel has multiple options for choosing a particular chart type. For example, if you want to 

create a column or bar chart, you are often presented with various visualization options. For 

example, there are 2D and 3D versions and normal, stacked, and 100% stacked options. 



Depending on your requirements, you can choose the visualization type that best suits your 

needs. 

 

Excel bar charts 

Bar charts are one of the easiest charts to interpret, enabling the person viewing the chart an 

easy way to compare categorical data quickly. On a bar chart, the categorical data is on the y-

axis, and the values are on the x-axis. 

To create a bar chart: 

 Select the data range A1:D13 

 Click the "Insert" tab in the Excel ribbon 

 Click on the columns icon button dropdown, and under the “2-D Bar” category, choose 

“Clustered Bar” 

 

 

Excel column charts 

A column chart, also known as a vertical bar chart, helps visualize data where categories are 

placed on the x-axis and the values on the y-axis. Similar to bar charts, they help visualize data 

across categories. 



To create a column chart in Excel: 

 Select the data range A1:D13 

 Click the "Insert" tab in the Excel ribbon 

 Click on the columns icon dropdown, and under the “2-D Column” category, choose “Clustered 

Column” 

You can now see a column chart that displays the number of units sold for each product 

category by the month.  

 

 

Excel line charts 

A line chart is the most useful way to capture how a numerical variable changes over time. This 

is helpful to identify trends in numeric values. 

To create a line chart in Excel: 

 Select the data range A1:D13 

 Click the "Insert" tab in the Excel ribbon 

 Click on the line chart dropdown, and under the “2-D Line” category, choose “Line with 

Markers" 

You can now see a line chart displaying units sold each month split by product category. This 

enables you to compare each product category's performance over time easily.  

 



Excel pie charts 

A pie chart is most commonly used to show the proportions of a whole. It‟s like visualizing 

fractions when you were in high school. With this pie chart, we want to compare the total sales 

between the three categories. 

To create a pie chart in Excel: 

 First, select the data range B1:D1 

 Second, using the command (for Mac) or ctrl (for Windows), select the second date range: 

B14:D14 

 Click the "Insert" tab in the Excel ribbon 

 Click on the pie chart dropdown, and under the “2-D Pie” category, choose “Pie” 

 

5.3 Background Conditional Formatting 

 Conditional formatting is used to change the appearance of cells in a range based on your 

specified conditions. 

 The conditions are rules based on specified numerical values or matching text. Changing 

the appearance of cells can visually highlight interesting data points for analysis. 

 The browser version of Excel provides a number of built-in conditions and appearances: 

 



5.3.1 Highlight Cell Rules 

 Highlight Cell Rules is a premade type of conditional formatting in Excel used to change 

the appearance of cells in a range based on your specified conditions. 

 The conditions are rules based on specified numerical values, matching text, calendar 

dates, or duplicated and unique values. 

 Here is the Highlight Cell Rules part of the conditional formatting menu: 

 

Appearance Options 

The web browser version of Excel offers the following appearance options for conditionally 

formatted cells: 

 Light Red Fill with Dark Red Text 

 Yellow Fill with Dark Yellow Text 

 Green Fill with Dark Green Text 

 Light Red Fill 

 Red Text 

 Red Border 

Here is how the options look in a spreadsheet: 

 



Cell Rule Types 

Excel offers the following cell rule types: 

 Greater Than... 

 Less Than... 

 Between... 

 Equal To... 

 Text That Contains... 

 A Date Occurring... 

 Duplicate/Unique Values 

Highlight Cell Rules - Greater Than 

Greater Than... is one of the options for the condition. 

The "Greater Than..." Highlight Cell Rule will highlight a cell with one of the appearance 

options based on the cell value being greater than to your specified value. 

The specified value is typically a number, but it also works with a text value. 

In this example, the specified value will be "65". 

 

You can choose any range for where the Highlight Cell Rule should apply. It can be a  few 

cells, a single column, a single row, or a combination of multiple cells, rows and columns. 

"Greater Than..." Highlight Cell Rule, step by step: 

1. Select the range C2:C8 for HP values 

2. Click on the Conditional Formatting icon  in the ribbon, from Home menu 

3. Select the Highlight Cell Rules from the drop-down menu 

4. Select the Greater Than... from the menu 
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This will open a dialog box where you can specify the value and the appearance option. 

5. Enter 65 into the input field 

6. Select the appearance option "Green Fill with Dark Green Text" from the dropdown 

menu 

 

Now, the cells with values greater than "65" will be highlighted in green: 

 

Gyarados, Lapras and Vaporeon have HP values greater than 65, so they are highlighted. Value 

65 is not highlighted because rule does not include the specified value itself. 

Highlight Cell Rule - Greater Than Example (with Text) 

The "Greater Than..." Highlight Cell Rule also works with text values. 

Excel will use alphabetical order (A-Z) to highlight the text values that starts with a letter that 

is later in the alphabet than the specified value. 

In the above data set example, the specified text value will be "Gyarados". 



"Greater Than..." Highlight Cell Rule, step by step: 

1. Select the range A2:A8 for Name values 

2. Click on the Conditional Formatting icon  in the ribbon, from Home menu 

3. Select the Highlight Cell Rules from the drop-down menu 

4. Select the Greater Than... from the menu 

This will open a dialog box where you can specify the value and the appearance option. 

5. Enter Gyarados into the input field 

6. Select the appearance option "Yellow Fill with Dark Yellow Text" from the dropdown 

menu 

 

Now, the cells with text values later in the alphabet than "Gyarados" will be highlighted in 

yellow: 

 

Magikarp starts with "M", Lapras with "L", Vaporeon with "V", and Jolteon with "J". 

"M", "L", "V", and "J" are all later in the alphabet than "G", which Gyarados starts with, so 

these all are highlighted. 

But, what about the rest of the letters in the text value? 

Let's see what happens if we add a fictional pokemon with a new name: 



 

Notice that the fictional "Gzarados" is highlighted. 

The Excel condition checks each letter in the specified text value from left to right. 

Because the "z" in "Gzarados" comes later in the alphabet than the "y" in "Gyarados", this is 

considered Greater Than and is highlighted. 

Highlight Cell Rules - Less Than 

Less Than... is one of the options for the condition. 

The "Less Than..." Highlight Cell Rule will highlight a cell with one of the appearance options 

based on the cell value being less than to your specified value. 

The specified value is typically a number, but it also works with a text value. 

In this example, the specified value will be "55". 

"Less Than..." Highlight Cell Rule, step by step: 

1. Select the range D2:D8 for Attack values 

 

2. Click on the Conditional Formatting icon  in the ribbon, from Home menu 



3. Select the Highlight Cell Rules from the drop-down menu 

4. Select the Less Than... from the menu 

This will open a dialog box where you can specify the value and the appearance option. 

5. Enter 55 into the input field 

6. Select the appearance option "Light Red Fill with Dark Red Text" from the dropdown 

menu 

 

Now, the cells with values less than "55" will be highlighted in red: 

 

Highlight Cell Rule - Less Than Example (with Text) 

The "Less Than..." Highlight Cell Rule also works with text values. 

Excel will use alphabetical order (A-Z) to highlight the text values that starts with a letter that 

is earlier in the alphabet than the specified value 

In this example, the specified text value will be "Electric". 

Let's apply the rule to the Type 1 values. 

"Less Than..." Hightlight Cell Rule, step by step: 

1. Select the range B2:B8 for Type 1 values 

2. Click on the Conditional Formatting icon  in the ribbon, from Home menu 

3. Select the Highlight Cell Rules from the drop-down menu 

4. Select the Less Than... from the menu 

This will open a dialog box where you can specify the value and the appearance option. 



5. Enter Electric into the input field 

6. Select the appearance option "Yellow Fill with Dark Yellow Text" from the dropdown 

menu 

 

Now, the cells with text values earlier in the alphabet than "Electric" will be highlighted in 

yellow: 

 

Nothing seems to have changed! 

Water starts with "W" and Normal starts with "N". 

"W"and "N" are all later in the alphabet than "E", which Electric starts with, so none of these 

are highlighted. The specified value “Electric” itself is not highlighted. If we add a fictional 

pokemon with a new Name and Type: Ficteon and eclectic 

 



Notice that the fictional "Ficteon" has the type "Eclectic", which is highlighted. 

The Excel condition checks each letter in the specified text value from left to right. 

Because the "c" in "Eclectic" comes earlier in the alphabet than the "l" in "Electric", this is 

considered Less Than and is highlighted. 

Highlight Cell Rules - Between 

Between... is one of the options for the condition. 

The "Between..." Highlight Cell Rule will highlight a cell with one of the appearance options 

based on the cell value being between two specified values. 

The specified values is typically numbers, but can also be text values. 

In this example, the specified values will be "79" and "100". 

"Between..." Hightlight Cell Rule, step by step: 

1. Select the range C2:H8 for all of the stat values 

 

2. Click on the Conditional Formatting icon  in the ribbon, from Home menu 

3. Select the Highlight Cell Rules from the drop-down menu 

4. Select the Between... from the menu 

This will open a dialog box where you can specify the value and the appearance option. 

5. Enter 79 and 100 into the input fields 

6. Select the appearance option "Yellow Fill with Dark Yellow Text" from the dropdown 

menu 

 

Now, the cells with values between "79" and "100" will be highlighted in yellow: 



 

Notice that Gyarados' Defense and Special Defense, which are 79 and 100, are highlighted. 

The Between... condition includes the specified values. This is different from the Greater 

Than... and Less Than... conditions, which do not include the specified values. 

Highlight Cell Rules - Equal To 

Equal To... is one of the options for the condition. The "Equal To..." Highlight Cell Rule will 

highlight a cell with one of the appearance options based on the cell value being equal to your 

specified value. The specified value could be a particular number or particular text. 

In this example, the specified value will be "48". 

"Equal To..." Highlight Cell Rule, step by step: 

1. Select the range C2:H8 for all of the stat values 

 

2. Click on the Conditional Formatting icon  in the ribbon, from Home menu 

3. Select the Highlight Cell Rules from the drop-down menu 

4. Select the Equal To... from the menu 

This will open a dialog box where you can specify the value and the appearance option. 

5. Enter 48 into the input field 

6. Select the appearance option "Yellow Fill with Dark Yellow Text" from the dropdown 

menu 
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Now, the cells with values equal to "48" will be highlighted in yellow: 

 

Highlight Cell Rule - Equal To Example (with Text) 

The "Equal To..." Highlight Cell Rule also works with text values. 

In this example, the specified text value will be "Magikarp". 

Let's apply the rule to the Name values. 

"Equal To..." Hightlight Cell Rule, step by step: 

1. Select the range A2:A8 for Name values 

 



2. Click on the Conditional Formatting icon  in the ribbon, from Home menu 

3. Select the Highlight Cell Rules from the drop-down menu 

4. Select the Equal To... from the menu 

This will open a dialog box where you can specify the value and the appearance option. 

5. Enter Magikarp into the input field 

6. Select the appearance option "Yellow Fill with Dark Yellow Text" from the dropdown 

menu 

 

Now, the cells with text values equal to "Magikarp" will be highlighted in yellow: 

 

Highlight Cell Rules - Text That Contains 

Text That Contains... is one of the options for the condition. 

Highlight Cell Rule - Text That Contains Example (with Text) 

The "Text That Contains..." Highlight Cell Rule will highlight a cell with one of the appearance 

options based on a part of the cell value containing your specified value. 

The specified value is typically text, but also works with a numerical value. 

In this example, the specified value will be "Pidge". 

"Text That Contains..." Hightlight Cell Rule, step by step: 

1. Select the range A2:A8 for the Name values 



 

2. Click on the Conditional Formatting icon  in the ribbon, from Home menu 

3. Select the Highlight Cell Rules from the drop-down menu 

4. Select the Text That Contains... from the menu 

This will open a dialog box where you can specify the value and the appearance option. 

5. Enter Pidge into the input field 

6. Select the appearance option "Yellow Fill with Dark Yellow Text" from the dropdown 

menu 

 

Now, the cells with values Text That Contains "Pidge" will be highlighted in yellow: 

 



The names "Pidgey", "Pidgeot", and "Pidgeotto" all start with "Pidge", so all these cells are 

highlighted. 

Highlight Cell Rules - A Date Occurring 

A Date Occurring... is one of the options for the condition. The "A Date Occurring..." 

Highlight Cell Rule will highlight a cell with one of the appearance options based on the cell 

value relative to a specified time frame. 

The time frame can be: 

 Yesterday 

 Today 

 Tomorrow 

 In the last 7 days 

 Last Week 

 This Week 

 Next Week 

 Last Month 

 This Month 

 Next Month 

In this example, the specified time frame will be "next month". 

 



"A Date Occurring..." Hightlight Cell Rule, step by step: 

1. Select the range C2:C19 for the Birthday values 

 

2. Click on the Conditional Formatting icon  in the ribbon, from Home menu 

3. Select the Highlight Cell Rules from the drop-down menu 

4. Select the A Date Occurring... from the menu 

This will open a dialog box where you can specify the value and the appearance option. 

5. Select "Next Month" from the dropdown menu 

6. Select the appearance option "Yellow Fill with Dark Yellow Text" from the dropdown 

menu 

 



Now, the cells with values A Date Occurring next month will be highlighted in yellow, in this 

example current month is August. 

 

Highlight Cell Rules - Duplicate and Unique Values 

Duplicate Values.. is one of the options for the condition, and can check for 

both duplicate and unique values. 

The "Duplicate Value..." Highlight Cell Rule will highlight a cell with one of the appearance 

options based on the cell value being the same as other cells in the range. 

 

" Duplicate Value..." Hightlight Cell Rule, step by step: 

1. Select the range A2:H8 



 

2. Click on the Conditional Formatting icon  in the ribbon, from Home menu 

3. Select the Highlight Cell Rules from the drop-down menu 

4. Select the Duplicate Values... from the menu 

This will open a dialog box where you can specify the value and the appearance option. 

5. Select Duplicate 

6. Select the appearance option "Yellow Fill with Dark Yellow Text" from the dropdown 

menu 

 

Now, all the cells in the range that have the same value as another cell are highlighted in 

yellow. All of Ditto's stat values are 48 and all of Mew's stat values are 100, so they are all 

highlighted. All of the Dittos and all of the Normal Type values are also highlighted. 

 

 



Highlight Cell Rule - Unique Value Example 

The "Duplicate Values..." Highlight Cell Rule can also find and highlight Unique Values. 

Let's apply this to the same set of data. 

"Equal To..." Highlight Cell Rule, step by step: 

1. Select the range A2:H8 

 

2. Click on the Conditional Formatting icon  in the ribbon, from Home menu 

3. Select the Highlight Cell Rules from the drop-down menu 

4. Select the Duplicate Value... from the menu 

This will open a dialog box where you can specify the value and the appearance option. 

5. Select Unique from the dropdown menu 

6. Select the appearance option "Green Fill with Dark Green Text" from the dropdown 

menu 

 

Now, the cells with unique values will be highlighted in green. Mew and Psychic only appears 

once in the range, so these values are highlighted. 

 



 

5.3.2 Top/Bottom Rules 

Top/Bottom Rules are premade types of conditional formatting in Excel used to change the 

appearance of cells in a range based on your specified conditions. 

Here is the Top/Bottom Rules part of the conditional formatting menu: 

 

Top/Bottom 10 Items Example 

The "Top 10 Items..." and "Bottom 10 Items..." rules will highlight cells with one of the 

appearance options based on the cell value being the top or bottom values in a range. The 

default number of items is 10, but you can specify any whole number up to 1000 for 

Top/Bottom Items to be highlighted. 

First apply the Top 10 Items... rule to the Speed values. 

"Top 10 Items..." Rule, step by step: 

1. Select the range C2:C31 for Speed values 



 

2. Click on the Conditional Formatting icon  in the ribbon, from Home menu 

3. Select the Top/Bottom Rules from the drop-down menu 

4. Select the Top 10 Items... from the menu 

This will open a dialog box where you can specify the value and the appearance option. 

5. Leave the default value 10 in the input field 



6. Select the appearance option "Green Fill with Dark Green Text" from the dropdown 

menu 

 
Now, the 10 cells with the top values will be highlighted in green: 

 

Repeat the steps, but instead choose Bottom 10 Items... in the menu and select the "Light Red 

Fill with Dark Red Text" appearance option. 



Now, the slowest values are also highlighted: 

 

Top/Bottom 10% Example 

The "Top 10%..." and "Bottom 10%..." rules will highlight cells with one of the appearance 

options based on the cell value being the top or bottom percent of values in a range. The 

default percent of items is 10, but you can specify any whole number up to 100 for Top/Bottom 

Percent to be highlighted. 

Let's apply Top and Bottom 10% rules to the same dataset with sorted Speed values: 



 

"Bottom 10%..." Rule, step by step: 

1. Select the range C2:C31 for Speed values 

 

2. Click on the Conditional Formatting icon  in the ribbon, from Home menu 



3. Select the Top/Bottom Rules from the drop-down menu 

4. Select the Bottom 10%... from the menu 

This will open a dialog box where you can specify the value and the appearance option. 

5. Leave the default value 10 in the input field 

6. Select the appearance option "Light Red Fill with Dark Red Text" from the dropdown 

menu 

7. Now, the bottom 10% of cells will be highlighted in red: 

 

Notice that there are 3 highlighted cells. There are 30 cells in the range, so 10% of that is 3 

cells. 



Above and Below Average Rules 

Above and Below Average Rules are premade types of conditional formatting in Excel used to 

change the appearance of cells in a range based on your specified conditions. 

Above and Below Average Rules are found in the Top/Bottom Rules part of the conditional 

formatting menu. The "Above Average" rule will highlight cells with one of the appearance 

options based on the cell value being the above the average value in a range. 

 

"Above Average" Rule, step by step: 

1. Select the range C2:C11 for HP values 

2. Click on the Conditional Formatting icon  in the ribbon, from Home menu 

3. Select the Top/Bottom Rules from the drop-down menu 

4. Select Above Average from the menu 

This will open a dialog box where you can specify the value and the appearance option. 

5. Select the appearance option "Green Fill with Dark Green Text" from the dropdown 

menu 

 

Now, the cells with above average HP values (more than 77.2) will be highlighted in green: 



 

Repeat the steps, but instead choose Below Average in the menu and select the "Light Red Fill 

with Dark Red Text" appearance option. 

Now, the below average values are also highlighted: 

 

5.3.3 Data Bars 

Data Bars are premade types of conditional formatting in Excel used to add colored bars to cells 

in a range to indicate how large the cell values are compared to the other values. 

Here is the Data Bars part of the conditional formatting menu: 

 



 

 

Data Bars Example 

 

The size of the data bars depends on the smallest and largest cell value in the range. 

Let's apply the Data Bars conditional formatting to the Speed values. 

"Data Bars", step by step: 

1. Select the range C2:C10 for Speed values 



 

2. Click on the Conditional Formatting icon  in the ribbon, from Home menu 

3. Select Data Bars from the drop-down menu 

4. Select the "Green Data Bars" color option from the Gradient Fill menu 

Both Gradient Fill and Solid Fill work the same way. The only difference between those, and 

the color options are aesthetic. Now, all of the Speed value cells have a green bar showing how 

big the value is compared to the other values in the range: 

 

Electrode has the highest value, 140, so the bar fills the entire cell. The other bars are scaled 

relative to the highest value and 0 by default. Exeggcute has the lowest value, 40, so this is the 

shortest bar. Though, it is larger than 0, so there is still a small bar. 

Let's see what happens if we add a fictional Pokemon with a 0 Speed value: 



 

The fictional Neutrinode has a Speed value of 0, so this becomes an invisible "minimum" bar. 

5.3.4 Color Scales 

Color Scales are premade types of conditional formatting in Excel used to highlight cells in a 

range to indicate how large the cell values are compared to the other values in the range. 

Here is the Color Scales part of the conditional formatting menu: 

 

Color Scale Formatting Example 

Highlight the Speed values of each Pokemon with Color Scale conditional formatting. 

Color Scales, step by step: 

1. Select the range of Speed values C2:C8 



 

2. Click on the Conditional Formatting icon  in the ribbon, from the Home menu 

3. Select the Color Scales from the drop-down menu 

There are 12 Color Scale options with different color variations. The color on the top of the 

icon  will apply to the highest values. 

4. Click on the "Green - Yellow - Red Colour Scale" icon 

Now, the Speed value cells will have a colored background highlighting: 

 

Dark green is used for the highest values, and dark red for the lowest values. 

Rapidash has the highest Speed value (105) and Slowpoke has the lowest Speed value (15). 

All the cells in the range gradually change color from green, yellow, orange, then red.  The 

color formatting is relative to the smallest and largest cell values in the range. 



5.3.5 Icon Sets 

Icon Sets are premade types of conditional formatting in Excel used to add icons to cells in a 

range to indicate how large the cell values are compared to the other values in the range. Icon 

Sets can be used together with other conditional formatting rules. 

Icon Sets Options 

Excel has a number of different icon sets, organized as: 

Directional 

 

Shapes 

 

Indicators 

 



Ratings 

 

Add icons to the Speed values of each Pokemon with Icon Set conditional formatting. 

 

Icon Sets, step by step: 

1. Select the range of Speed values C2:C10 

2. Click on the Conditional Formatting icon  in the ribbon, from the Home menu 

3. Select the Icon Sets from the drop-down menu 

4. Click on the "3 Traffic Lights (Unrimmed)" option 



 

Now, the Speed value cells will have icons indicating how large the values are compared to the 

other values in the range: 

 

The green traffic light is used for the highest values, yellow for the middle values, and red for 

the lowest values. Excel automatically calculates and chooses which values get which colored 

traffic light icon. 

5.3.6 Excel Manage Rules 

Conditional Formatting rules can be managed and removed using the Clear Rules and Manage 

Rules features. 



Here is the Clear Rules part of the conditional formatting menu: 

 

You can remove all the rules from a selected range of cells or from the entire spreadsheet using 

the Clear Rules menu options. We can also use the Manage Rules menu option to clear 

conditional formatting rules. 

Let's remove the Color Scale rule applied to all the Stat values: 

 

Select the range C2:H9. 

Select the Manage Rules option from the Conditional Formatting menu  in 

the Home menu. 

This box will appear on the right-hand side of your spreadsheet: 



 

This will show all the active rules that are applied to the selected range. 

It will also indicate which cells the rule is applied to. Which, in this example, is C2:H9? 

 

Clicking on the recycling bin icon will remove a particular rule. 

 

Now, the cells no longer have conditional formatting. 

 

 



5.4 Visual level filter  

Filter a Chart in Excel on Windows 

You can certainly use Excel's data filter on the Home tab. But Microsoft makes applying a filter 

to a chart a bit simpler on Windows. 

Select the chart and you'll see buttons display to the right. Click the Chart Filters button (funnel 

icon). 

 

When the filter box opens, select the Values tab at the top. You can then expand and filter by 

Series, Categories, or both. Simply check the options you want to view on the chart, then click 

"Apply." 



 

Note that some chart types don't offer the Chart Filters option such as Pareto, Histogram, 

and Waterfall charts. You can still filter the chart by applying a filter to the data instead. Follow 

the steps below for filtering a chart on Mac as the steps are the same in Excel on Windows. 

Remove a Filter 

When you finish using the Chart Filters, click that button once more to open the filter box. 

Check the boxes for Select All in Series or Categories, depending on the filter you used. Then, 

click "Apply." 

https://www.howtogeek.com/747491/how-to-create-and-customize-a-pareto-chart-in-microsoft-excel/
https://www.howtogeek.com/678088/how-to-create-a-histogram-in-microsoft-excel/
https://www.howtogeek.com/747405/how-to-create-and-customize-a-waterfall-chart-in-microsoft-excel/


 

Your chart should then be back to its original view 

 

5.5 How to Publish an Excel Spreadsheet on the Web 

Start by opening the desired Excel spreadsheets in Microsoft Office Excel. 

 Open the File 

 Click Save As. 

 At the bottom of the window, click on the down arrow of the drop-down menu. 

 Select Web Page from the list. 

 In the File Name box, type an appropriate name for the file. 

 Click Publish. 

 

 



 

Sheet Option Button 

 

Change the Selection Option depending on whether part of the sheet is selected. If changes to 

the sheet are being saved, the button changes to Republish: Sheet. If nothing is selected, Excel 

will by default save the entire workbook. It will include all the data in the HTML file. 

To limit what gets included in the HTML file, select the appropriate items in the Choose 

List. It is possible to publish only one item at a time. To continue publishing, select a different 

element and follow the procedure outlined above. These are the publishable elements and a 

description of how to publish them: 

 The whole workbook. 



Select the whole workbook. Excel will publish it with all the associated interactivity. 

It is not possible to publish it with the interactive elements. 

 Complete worksheets. 

Select the sheet names, then select All Content of the sheet. 

 Items. 

Under Sheet Name select the desired items. Examples include PivotTable or a chart. 

Items do not include cell ranges. 

 Cell Ranges. 

Select the cell ranges. 

To select the right range, click on the worksheet. The dialog box will now collapse. 

Now, select the range by clicking and dragging. Then click on the Expand Dialog Button: 

 Charts. 

Select Items on Sheet. Then select the appropriate Chart. 

 Filtered ranges. 

Click Select Items on Sheet and then apply the AutoFilter. 

 External data ranges. 

Select Items on Sheet name. Then select the query item 

To republish part of a previously published workbook, click Previously Published Items. 

Select the elements to republish. 

Alternatively, select Remove to prevent an element from publishing again. Finally, click a 

different item on the list to continue publishing. 

It is also possible to add a page to the HTML file: 

 Click the Change 

 Type a heading in the Page Title text box in the Set Page Title box. 

 Click OK. The title will appear in the middle at the top of the page. 

This header is not the same as the web page title. 

 Click Save. 

 Close the Save As box. 

By default, Excel saves a single worksheet as HTM, a Hypertext Markup file. It uses the .mht 

extension if publishing multiple worksheets. 

Some file servers, in particular the ones that run on UNIX, are case-sensitive. So, keep the 

effect of capitalization in mind when choosing a file name. 

 



 
 

5.5 Excel Dashboard 

 

A dashboard is a visual representation of  Key Performance Indicators (KPIs), key business 

metrics, and other complex data in a way that‟s easy to understand. We can create both 

a static or dynamic dashboard in Excel. 

Static dashboards simply highlight data from a specific timeframe. It never changes.  

On the other hand, dynamic dashboards are updated daily to keep up with changes. 

Benefits of creating an Excel dashboard 

 Gives a detailed overview of  business‟ Key Performance Indicators at a glance 

 Adds a sense of accountability as different people and departments can see the areas of 

improvement 

 Provides powerful analytical capabilities and complex calculations 

 Helps you make better decisions for your business  

Steps To Create A Dashboard In Excel  

 

Step 1: Import the necessary data into Excel 

The first thing to do is to bring data into Microsoft Excel, if data already exists in Excel. Or 

import data to Excel.  

Step 2: Set up workbook 

Open a new Excel workbook and add two or more worksheets (or tabs) to it.  

https://clickup.com/blog/kpi-examples/
https://clickup.com/blog/business-metrics/
https://clickup.com/blog/business-metrics/


For example, let‟s say we create three tabs. 

Name the first worksheet as „Raw Data,‟ the second as „Chart Data,‟ and the third as 

„Dashboard.‟ This makes it easy to compare the data in your Excel file. 

 

Step 3: Add raw data to a table 

The raw data worksheet you created in your workbook must be in an Excel table format, with 

each data point recorded in cells. 

Step 4: Data analysis 

Take a good look at all the raw data  gathered, study it, and determine what you want to use in 

the dashboard sheet. 

Add those data points to your „Chart Data‟ worksheet. 

Analyzing your data will also help you understand the different tools you may want to use in 

your dashboard.  

Some of the options include: 

 Charts: to visualize data 

 Excel formulas: for complex calculations and filtering 

 Conditional formatting: to automate the spreadsheet‟s responses to specific data points 

 PivotTable: to sort, reorganize, count, group, and sum data in a table 

 Power Pivot: to create data models and work with large data sets  

Step 5: Determine the visuals 

The next step is to determine the visuals and the dashboard design that best represents your 

data. 

You should mainly pay attention to the different chart types Excel gives you, like: 

 Bar chart: compare values on a graph with bars 

 Waterfall chart: view how an initial value increases and decreases through a series of 

alterations to reach an end value 

 Pie chart: highlight percentages and proportional data 

 Dynamic chart: automatically update a data range 

 Pivot chart: summarize your data in a table full of statistics 

Step 6: Create your Excel dashboard 

To explain the process of creating a dashboard in Excel, we‟ll use a clustered column chart.  

A  clustered column chart consists of clustered, horizontal columns that represent more than one 

data series. 

Start by clicking on the dashboard worksheet or tab that you created in your workbook. 

Then click on „Insert‟ > „Column‟ > „Clustered column chart‟. 



If you notice your horizontal axis doesn‟t represent what you want, you can edit it. 

All you have to do is: select the chart again > right-click > select data. 

The Select Data Source dialogue box will appear.  

Here, you can click on „Edit‟ in the „Horizontal (Category) Axis Labels‟ and then select the 

data you want to show on the X-axis from the „Chart Data‟ tab again. 

                                    
To give a title to your chart: Select the chart and then click on Design > chart layouts. Choose 

a layout that has a chart title text box. Click on the text box to type in a new title 

Publishing  

Once you have created the spreadsheet in your computer you can then create a shareable link 

and multiple users can access that report. And sure enough the report will be dynamic with all 

the slicers, buttons and fancy controls working in sync.  

Save the Excel file to OneDrive 

1. Make sure you have a OneDrive account. It is free! 

2. Go to File and Click on Save As (make sure one drive is selected) 

3. Then go to More Options 

4. And then in the popup window choose Browser View Options 

 

https://onedrive.live.com/about/en-in/


5. Under Show Tab – check Screen 1 and Screen 2 (the 2 named ranges) 

  

Now Share the workbook 

 

1. Go to the right hand top corner of the excel screen and click on Share. You can also find 

the sharing option in the File menu in the older versions of Excel (version 2010 – 2013) 

2. Then choose Get a Sharing Link 

3. Excel will offer you 2 types of links 

1. Links for editing 

2. Links for viewing only 

4. Copy  the view only link and send this link to anyone! 

If you make any changes in the excel file (which will now also be saved on your local computer 

and on Onedrive) the users can instantly refresh the link and view the changes! 

  



The pros & cons 

One of the biggest pro is that it can massively reduce duplicate excel files floating around. 

Take a look! 

 

One of biggest con is security of data if anyone has the link to your online dashboard they get 

to see your numbers! So cautious about that 

It still is largely helpful in presenting non confidential information to multiple users! 

  

 

 

 



 


